[Frontend] Error affecting customer checkout
Incident Report for Shogun
Postmortem

On December 15th at 5:52 PM EST, Shogun received a report from a customer indicating issues updating quantities within shopping carts. The Shogun Engineering team immediately began responding to the issue and began assessing the root cause. Upon further investigation, the team noticed an API call to the Shopify platform was throwing an error once a shopping cart had an item added to it. This error prevented further modifications to the shopping cart itself, including adding additional items, adjusting quantities, and removing items from the cart. This issue was widespread and affected multiple sites hosted on Frontend.

Shogun contacted Shopify support to make them aware of the issue and immediately began working on a workaround to the problem. At 9:43 PM EST Shogun’s Engineering team completed the necessary updates to work around the problematic Shopify API. Shogun is continuing to work with Shopify on a full resolution to the issue. We have contacted all stores that we have identified to have been impacted. We apologize for any inconvenience this issue may have caused.

Posted Dec 16, 2022 - 11:52 UTC

Resolved
This issue has now been resolved and a fix has been implemented. We continue to work together with Shopify on a long-term solution, however, customer checkout is no longer affected. Clients that were affected by the change will receive an email with further information relating to the fix provided.
Posted Dec 16, 2022 - 06:40 UTC
Monitoring
This issue has now been resolved and a fix has been implemented. We continue to work together with Shopify on a long-term solution, however, customer checkout is no longer affected. Clients that were affected by the change will receive an email with further information relating to the fix provided.
Posted Dec 16, 2022 - 02:31 UTC
Update
We have identified a temporary workaround in order to address the issue and will implement this shortly. We are also continuing to work together with Shopify on a long-term solution.
Posted Dec 16, 2022 - 01:10 UTC
Identified
We have identified the issue and are working together with Shopify to resolve it.
Posted Dec 16, 2022 - 00:09 UTC
Investigating
We are currently investigating an issue with customer checkouts. This includes, for example, the ability to add multiple items to the cart.
Posted Dec 15, 2022 - 23:23 UTC