As planned, we have moved our Big Commerce API calls to a new endpoint. Merchant's customers on Strict Mode (high privacy) will be able to view BigCommerce Product Elements on pages.
Note that merchants will need to republish affected pages for the change to take effect. If accessing your store via a VPN, please contact Support for the new URLs to add to your allowlist.
Posted Aug 19, 2024 - 17:30 UTC
Update
Shogun Engineering will be switching API calls for Big Commerce merchants away from getshogun.com to a new domain on Monday, August 19th. We will be continuing to test the impact of this change before we do so.
After this change has been made, merchant's customers on Strict Mode (high privacy) will be able to view BigCommerce Product Elements on pages.
This change will require a republish of merchant's pages so we will follow up here when the switch has been made.
Posted Aug 14, 2024 - 19:05 UTC
Identified
Up until Monday, August 12th, 2024, Shogun utilized the getshogun.com domain for serving the following functionality’s for merchant’s pages:
Due to a policy change effecting only customers who are using Strict Mode in their browsers, some Shogun-created pages previously displayed incorrectly under those conditions. To resolve this we have moved #1 - #3 to different Shogun owned domains.
If an affected page is republished in Shogun, styling and analytics tracking is restored and the issue is resolved. Please note that browser cache does need to clear so it may take a few hours up to a day to see the changes.
We're aware of the issue related to #4 that is currently being worked on by the Shogun Engineering team, and we will provide an update here once it has been released.