Shogun is experiencing slow load times
Incident Report for Shogun Page Builder
Resolved
This incident has been resolved.
Posted Sep 29, 2020 - 19:42 UTC
Investigating
We are currently investigating the issue.
Posted Sep 29, 2020 - 16:11 UTC