Slow loading of the Shogun Page Builder Editor

Incident Report for Shogun

Resolved

The Shogun editor should be loading correctly now. If you continue to encounter issues, please reach out to our aupport team at support@getshogun.com. Thanks.
Posted Jan 29, 2026 - 10:05 UTC

Investigating

We've become aware that in some instances the Shogun editor is either loading slowly, or failing to load entirely. We're investigating this and will provide an update when we know more.
Posted Jan 28, 2026 - 21:58 UTC
This incident affected: Shogun Core Services.